Interface not found

edited December 1969 in Electroacoustics Toolbox
I just upgraded my Mac Minis to Mtn Lion, downloaded V 3.3 of FEAT, and new drivers for my TASCAM interfaces (US-144mkII and US-1800). Everything but FEAT recognizes the interfaces and works properly. The interfaces do not appear at all in the I/O device list. Same problem on two Macs upgraded at different times. Any ideas?

Comments

  • H3nry,

    You are the second user to report this. I have never observed this issue on Mountain Lion, with either the App Store or non-App Store versions of Electroacoustics Toolbox.

    Did you download the Toolbox from the App Store? Are you aware of any security restrictions in place on your Macs that might affect the appearance of USB devices in the audio device list?

    Electroacoustics Toolbox acquires the current list of audio devices from the Mac OS, so I suspect that there's a fairly simple explanation/solution to this issue.

    Thanks,

    Ben
  • The app was downloaded from the App Store. I don't know of any restrictions. FEAT worked properly on the older Mini before the upgrade of the OS and app. The TASCAM interfaces appear in Audio Midi Setup, Logic, Audacity, and GarageBand. FEAT finds my composite "Built-in I/O" interface and Soundflower. Same behavior on a a new Mini which shipped with Mtn Lion, so it appears to be 10.8 / 3.3 specific.

    If there are any tests you'd like me to try, I'm happy to help.
  • What was the last version of the Toolbox that you know presented all your devices in the list?
  • I was last using version 3.1.2 with OS 10.6.8. The TASCAM software went from version 2.00 to 2.10.

    Attached is HALLab info on the US-1800, FWIW.
  • Hello? Anyone home?
  • H3nry,

    I'm sorry for leaving you hanging. I still haven't been able to reproduce the problem, and I have been working with USB and FireWire audio interfaces, including a Tascam US-800.

    Does it matter whether you use an admin or non-admin account? Does the problem persist with version 3.4 of the Toolbox? Also, are you running 10.8.4?

    Thanks,

    Ben
  • The problem is still present with 10.8.4 and Toolbox 3.4. Admin account. I haven't tried setting up a non-admin account. I'll try that and see what happens.

    If I set up a new aggregate interface such as "Built-in I/O" of built-in i + O, it appears immediately in Toolbox. Likewise if I plug in a generic USB i/f like an iMic it appears, but neither TASCAM USB interface appears in either of the Minis. Unplugging and re-plugging the TASCAM has no effect.

    Each Mac had the OS installed from scratch, so there ought not to be any weird extensions in common. The odd thing is, no other app is having a similar problem, including iTunes, Audio MIDI setup, Audacity, Logic Studio, Garageband, Audio Test, or Fuzzmeasure (trial version), nor does there seem to be any interaction between apps.

    Your US-800 is OK with the latest software (2.10)?
  • What are you referring to by "latest software (2.10)"?

    I'm still baffled by this. Do you have any other audio apps running when you launch Electroacoustics Toolbox?
  • Latest TASCAM software is version 2.10 from their website. It doesn't matter whether any other software is running or not. I've tried running other apps which use the interfaces and then launch Toolbox, and I've tried cold shutdown and boot running only Toolbox. Toolbox never sees either TASCAM.

    The annoying thing is, Toolbox was working on the older Mini under OS 10.6.8. The AppStore updated Toolbox automatically, without notice that the new version was not Snow Leopard compatible. That pushed me to upgrade the OS to 10.8, which forced an update to the TASCAM software, along with a bunch of other stuff. Now everything works except Toolbox and of course old apps which relied on Rosetta.

    But the new Mini which shipped with OS 10.8 has exactly the same issue, and with both drivers for the US1800 and the US1xx series. Whatever broke must be in the code specific to OS 10.8.
  • Tascam's last version of the Mac drivers for the US-800 is 1.0.9, which has not been updated specifically for 10.8 (Mountain Lion).

    Is it possible for you to uninstall version 2.10 for the US-1800 and install version 2.0 instead? Maybe it's a Tascam driver issue.
  • The version 2.0 driver is not compatible with OS 10.8. As mentioned, the Toolbox update is not compatible with OS 10.6, so I had to update the OS, and that forced an update to the TASCAM 2.10 driver. The 2.0 driver works with the old MacOS and old version of Toolbox, but since I've updated everything else, I can't really go back to Snow leopard on the older Mac, and the new Mac *requires* 10.8.

    The US-800 seems to use a different software structure. I tried installing it to see what it is like, and it does not install a driver in /Library/Audio/Plug-Ins/HAL/ like the US-1xx series and the US-1800 do. I presume the US-800 has newer firmware which doesn't require installing a plug-in.
  • I have acquired a Tascam US-144mkII for testing and can confirm that it does not appear in the device list in Electroacoustics Toolbox. At least now, I can start digging for a real solution to this problem.
  • To complicate matters, Apple has released Mavericks OS, and TASCAM is revising drivers for the US-xxx series interfaces. This may or may not resolve the problem with Toolbox. :roll:
  • It turns out that the problem occurs when sandboxing is enabled for an app. Sandboxing is required for all app submissions to the Mac App Store, which is why this problem only affects the App Store version of the Toolbox. It would also seem that Tascam could solve the problem with their own drivers, since many other audio devices (including many of their own) work fine with sandboxing enabled.
  • The other apps I use with the interfaces came from the App Store, so they would presumably be sandboxed. If I open the demo of Toolbox from this website, it recognizes both interfaces, so I can confirm the diagnosis. With luck, TASCAM will address the issue in the Mavericks drivers.
  • :-D Happy to report TASCAM has released new drivers for their US-xxx interfaces which add Core Audio support as well as the previous direct "bit-accurate" type. The Core Audio interface works with FEAT and other App Store applications.
Sign In or Register to comment.
© 2021 Faber Acoustical, LLC | Terms and Conditions | Privacy Policy

We use cookies and similar tracking technologies on our website. This enables us to enhance your experience, provide certain website features and functions, and to improve the services we offer. Learn more in our Privacy Policy.