Welcome, Guest. Please login or register.

Login with username, password and session length
 

News:



Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - KenSchwarz

Pages: [1]
1
SignalScope / Signal Generator output on an analog oscilloscope
« on: April 17, 2012, 08:48:21 AM »
Hi,

I'm interested in exploring the effects of various components on sweep signals. I'm using SignalScope 3.0.4 Signal Generator as a sweep generator and an analog oscilloscope to look at it. The sweep takes about 1/10 to cover a 0-20kHz range. According to the doc, the log sweep (which I am using) exhibits a pink magnitude response--i.e., a 3db/oct. drop in magnitude with increasing frequency.

On the oscilloscope, I see the attached trace. This is a single sweep photographed with a second-long exposure. The trigger is set so that the scope sweep starts with the signal generator frequency sweep, so the low frequency signal is on the left and the wavelength gets progressively shorter as you move to the right.

I'm puzzled, though, why the overall waveform rises as frequency rises. I can't understand where that rising DC offset would come from. Also, does the tapering look right to you--3 db/oct. seems to take a long time to kick in and then it does with a vengeance at the end...is that to be expected with a logarithmic sweep?

I see a similar tapering and rising envelope phenomenon with the linear sweep--but it's very hard to get a stable trace that shows the whole thing for a photo, so I won't include it here.

Finally, the doc says that the high and low frequency limits for the sweep depend on the settings of the FFT portion of the suite, but no matter where I set the high frequency limit in that app, the sweep seems to run the same range. Am I missing something?

Thanks for any help you can offer!

- Ken

Pages: [1]