Faber Acoustical Forum

Faber Acoustical iOS Apps => SignalScope => Topic started by: DustinBoyle on September 08, 2008, 07:58:57 PM

Title: Bug discovered?
Post by: DustinBoyle on September 08, 2008, 07:58:57 PM
Hello everybody first post here. 

Please excuse me if this is in the wrong area, I did not see a bug report forum.  So please move if necessary.

I recently experienced some odd behavior after receiving a text message while using SignalScope in its spectrum analyzer mode.

After said text message the Spectrum Analyzer would "analyze" at a much faster speed and it would lock up.  No switching to Waveform, no zooming in, no picture, and I couldn't stop it from analyzing at the much faster rate until I turned off my iPhone.

I tried to sync back to iTunes, (I originally bought it from the iPhone itself) and I lost it from my phone along with it also not appearing in iTunes.

If I try to download it again it wants me to purchase it again despite it showing up in my recent purchases?

I've reported a problem from my purchase history and sent iTunes support an email so I'll see what comes back to me.

I just wanted you to know that a text message seemed to throw the entire program out of whack.
Title: Re: Bug discovered?
Post by: FaberAST on September 09, 2008, 08:22:27 AM
Dustin,

We're looking into the text messaging interruption problem.

What happens when you try to re-download SignalScope? If you are using the same iTunes account, it may appear that you are expected to purchase the app again, but when you proceed, iTunes should indicate that you have already purchased the item and ask you for confirmation to download it again.

Ben
Title: Re: Bug discovered?
Post by: DustinBoyle on September 09, 2008, 08:30:29 AM
If I click on it either in iTunes or on my iPhone it asks are you sure your credit card will be charged.  I have yet clicked yes because in the past getting refunds has been a headache for me so I a little leary of clicking yes in fear that it will charge my card.

edit: and yes it is the same iTunes account.
Title: Re: Bug discovered?
Post by: DustinBoyle on September 09, 2008, 08:35:57 AM
also I feel I should mention, before it disappeared from my iPhone, the app would function normally until I pressed start within the spectrum mode.  But if I didn't press start in spectrum mode I could still use the waveform mode with no problems as well as change any options as normal.  It was only after I pressed start did the freaking out occur. 

And the text message occured while I was in the middle of analyzing in spectrum mode.

Other than this small error and it disappearing altogether I think this is a really cool app and can't wait to see what becomes of it.  Great job!
Title: Re: Bug discovered?
Post by: DustinBoyle on September 11, 2008, 04:17:13 PM
Update;

Apple has reauthorized signalscope for download on my iTunes account and it is now on both my iPhone and applications section in itunes so I can continue to use this cool little app.

I'm curious to know if team Faber ever found anything out regarding text messages whilst using their app.