Faber Acoustical Forum

Faber Acoustical Products for Mac => Electroacoustics Toolbox => Topic started by: boboq on February 21, 2007, 08:58:45 AM

Title: Background noise in spectrograms
Post by: boboq on February 21, 2007, 08:58:45 AM
I just downloaded Electroacoustics toolbox 1.1 and have been playing with the Spectrogram. I am trying to set the display to the old fashioned black on white but find that there appears to be a lot of background noise so that is is hard to  see the formants on the spectrogram clearly. I am using a USB microphone but the display with that is not a whole lot clearer than what I get using the built-in mic on my MacBook Pro.

I was wondering if there is a setting I am missing that would allow me to filter the input a bit so that I could display a clearer signal.

Thanks in advance. This is a great program!

Bob Q.
Title: Re: Background noise in spectrograms
Post by: FaberAST on February 21, 2007, 10:37:19 AM
Bob,

If you click on the Scale tab, you will see the Ceiling and Floor controls.  If you increase the floor, you should be able to eliminate a lot of the low-lovel noise in the spectrogram image.

Ben
Title: Re: Background noise in spectrograms
Post by: FaberAST on March 01, 2007, 06:38:39 AM
I forgot to mention that using different data window types can also affect the amount of spectral leakage, which may also clear up some of the unwanted noise.  I would recommend trying a Hann (hanning) or Rife-Vincent window.

Ben